Pointers for upgrading your blog to WP 3.2 ...

WordPress related discussion.

Moderator: Inner Sanctum

User avatar
sysadm
Site Admin
Posts: 72
Joined: Mon Dec 13, 2010 6:12 pm

Pointers for upgrading your blog to WP 3.2 ...

Postby sysadm » Fri Jul 08, 2011 3:36 pm

Last week, I received a notice from the fine folks at WordPress that it was time for another release - v 3.1.4. That didn't suprise me with the news of Matt and Auttomatic and WordPress getting hacked, so I made an entire server backup, made the upgrade, and continued on with no problem. I even made a post on the fourth, which was after the fact.

Then, last night, I received another notice to upgrade to 3.2. I was tired and just hit the automatic upgrade option, and lo and behold, my blog was broken.

Since I didn't make a backup that time, I was kicking my own-self for the negligence, however, I've been in dire straits before (far worse than this) and decided to re-install the last stable version of WP, which was v 3.1.2. That changed nothing, and I still couldn't access my own admin dialogue. So, I decided to restore the entire server from my backup of last week, thinking that all I would have to remedy would be the 4th of July post that I made Monday. Then I went to bed thinking that with a rested brain I would better be a better to tackle the dilemma in the morning. This morning!

At 5:00 am, I couldn't sleep anymore and had horrific dreams about computers, websites, blogs and social site settings so I got up and threw myself into the mix.

I read a post on the WP support forum where many users where having severe problems with the new release, but the moderator wrote "Do not panic! All forum rules still apply. Just be patient and we will get to you to help your case. You, also, must help us. Reading a little further down his post. I gained some insight (actually re-assuring insights I already had), proceeded to unravel my situation piece by piece. Everything fell into place, almost smoothly.

Looking back on what I did, the solution that worked for me did not make sense. I did a complete restore last night. This morning, I copied my plugins folder into a backup and deleted everything out of the original. At least I got my blog pages up without the plugins, though still had no access to the admin panel. I then (after several other things), FTP'd the latest version of WP - 3.2 into the server and copied the plugins back in, then activated them one-by-one.

It all works!

So I decided to make another server wide backup. While doing that, I noticed that the restore from last night did not complete successfully! Perhaps if it had - I wouldn't be writing this, I'd still be thinking up nasty things to write on the support forum.

Whew!
Steve D.

Who is online

Users browsing this forum: No registered users and 1 guest